Prêt pour Firefox 4

Les versions beta de Firefox 4 sont disponibles depuis plusieurs mois déjà et, d'habitude, je m'empresse d'utiliser ces pré-versions. Sauf cette fois-ci, alors même que les nouveautés annoncées sont plutôt alléchantes. Pourquoi ? A cause de l'incompatibilité d'une extension que j'utilise quotidiennement et dont l'absence est était rédhibitoire...

Cette extension s'appelle brief, LE gestionnaire de flux RSS. Sans elle, difficile de suivre la soixantaine de sources d'informations que je consulte plusieurs fois par jour. La version actuellement disponible (1.2.5) n'est pas compatible avec Firefox 4, mais la dernière beta (1.5) l'est. Je n'ai donc plus aucune raison de ne pas effectuer la transition.

Pour ce faire, la première étape consiste évidemment à installer Firefox 4, de préférence à côté de Firefox 3.6. C'est possible sous Ubuntu en utilisant le dépôt « Ubuntu Mozilla Daily Build Team ».

Ensuite, si les extensions sur mozilla addons ne sont pas compatibles avec Firefox 4, 2 solutions s'offrent à vous :

  • Vérifier si une version compatible n'est pas disponible sur le site de l'extension ; attention cependant : n'installer des extensions en dehors du site mozilla addons que depuis des sites de confiance - les liens donnés ci-dessous sont dignes de confiance.
  • Désactiver la vérification de compatibilité. Là encore, attention : installer des extensions qui ne sont pas compatibles avec la version de Firefox utilisée peu rendre le navigateur web instable.

Pour désactiver la vérification de compatibilité, il suffit de taper dans le champ adresse « about:config ». Une fois la liste des options affichées, faites un clic-droit puis « New -> Boolean » ; dans la fenêtre de dialogue, tapez la préfrérence « extensions.checkCompatibility.4.0b » puis la valeur « false ». Vous pouvez ensuite installer des extensions pour Firefox 3.x sur un Firefox 4.0.

Vous pouvez aussi installer des versions pensées pour Firefox 4 mais qui ne sont pas encore totalement finalisées. C'est le cas de firebug 1.7 et Brief 1.5.

Reste encore une extension indispensable qui - si elle est utilisable - n'est pas encore totalement compatible : Scrapbook.

Titre
Firefox 4: Besoin de beta testeur linuxien
Auteurs
  • ARWENN
Éditeur
Forum Ubuntu-fr
Date
Titre
Extensions.checkCompatibility
Auteurs
  • COLLECTIF
Éditeur
MozillaZine
Date
Titre
Reduce the Firefox 4 menu button to an icon in Linux
Auteurs
  • Joey SNEDDON
Éditeur
OMG! Ubuntu!
Date

La version 1.5 de Brief, compatible avec Firefox 4, est maintenant disponible directement sur le site de Mozilla addons.

ScrapBook en version 1.4 est maintenant compatible avec Firefox 4.