JsValidator 0.7.1 : correction de bug sous Lucid Lynx

Comme expliqué précédemment, il n'y a plus de paquet spidermonkey sous Lucid Lynx. Cela ne m'inquiétait pas outre mesure pour le plugin Gedit JsValidator jusqu'à ce que j'ai à valider un fichier javascript avec Rhino. Et là, c'est fût le drame...

La discrimination entre les deux moteurs s'effectuait en testant la présence du fichier /usr/bin/js, lien symbolique vers spidermonkey ; sauf que maintenant ce lien symbolique pointe vers Rhino. Ce qui fait que l'extension pense utiliser Spidermonkey alors qu'elle lance Rhino.

La version 0.7.1 est donc juste une version de maintenance, en attendant la 0.8 qui devrait mettre à disposition les options de configuration de JsLint.

projet.gedit-jsvalidator